https://help.tallysolutions.com/docs/td9rel54/td9/using_the_editor/working_with_file_tabs.htm

Working with File Tabs

A tab Toolbar appears at the bottom of the Editor Window. It displays all the opened files as separate tabs. Each tab will represent an open file. Any number of tabs can be open at a time.

As stated before, the position of the Tab toolbar can be altered, or it can made to disappear at all, from Edit/Style Options in Tools > Preferences .

Whenever a file is opened by selecting it in Project Browser, a Tab for same appears in the Tab Toolbar. The same holds true whenever a file is opened by performing the Drag and Drop operation, i.e., using the mouse to drag the file from its location to the Tally.Developer9 Window.

The features related to the tabs are:

The name of an open file in the tab will be followed by an asterisk (*) sign, in case the file contains unsaved changes, e.g., File1.txt* .

In case the file contains any syntactical errors, the name of the file will be displayed in ‘Red’ colour instead of the default ‘Black’ colour, e.g., File1.txt . When this Tab is right-clicked, an option Go To Error is displayed. Selecting this option moves the focus to the first among the errors present in the file. Thus, the program can be debugged easily. The filename color changes to Black if there are no further errors.

The options Open File Location and Copy Path To Clipboard are present in the right-click menu to browse to the location of the file, and to copy the path of the file to clipboard, respectively.

The option Close All But This can be used to close all the file tabs, excluding the File from whose File Tab the right-click menu has been launched.

Among the currently open files, the name of the file which is currently active, will be displayed in bold in the tab, e.g., File1.txt .

When the mouse is hovering over a File Tab, the path/location of the file is displayed as tooltip.

The Ctrl + Tab key combination can be used to toggle across the file tabs.

Note : Currently open files refers to all the open files (which are visible in the form of tabs), while Currently active file refers to the open file which is currently visible in the Editor window.