https://help.tallysolutions.com/docs/td9rel54/td9/tally_developer_tools/manage_customer_serials.htm

Managing Customer Serials

Customer Serial Management in Tally.Developer 9 helps to manage customer data. It helps users to organise and store data effectively, and efficiently. It allows quick addition of customer serials to a .tcp file, and thus, faster delivery.

The Tally.Developer 9 user can stamp a .tcp file with the serial number(s) of a customer or a group of customers.

To manage customer serials

Go to Tools > Manage Customer Serials .

OR

Go to File > Project Properties > Build Options .

Refer to Generating TCP for Target Serials for more details.

Manage Customer Serials includes:

A standardised dialog box

An option that allows editing of serials

Import/export of serials through Excel

Ability to group the serials

The standardised dialog box will open:

In the standardised dialog box, the developer can create customers and groups by selecting the options New Customer and New Group , respectively. The details associated with a customer are the Customer Name , name of the Group to which it belongs, Customer Serial No. , and the Customer email ID. A customer can be associated with a group or a number of groups. If a customer is not associated to any group, the corresponding serial number will get listed under the default group Other Customers .

To create a new Group, select the option New Group .

A dialog box Create New Group will appear. A group name can be entered, and if customers are already present, they can be associated to this group. There is also an option to Set this as Default Group , as a result of which, customers will by default get added to this group, if they are not associated to any other group. For example, let us create two groups, Group 1 and Group 2 .

To create New Customers, click New Customers .

A dialog box Add New Customer will open. The customer name and the other details can be entered in this dialog box. Invalid Serials Numbers will not be accepted. The customer can also be associated with a group/groups, by clicking on the respective check box. These details can be modified at any point of time.

After the creation of the customers and the groups, the standardized dialog box of Manage Customer Serials will appear as shown below:

Click Save to save the changes.

By selecting a Group/Customer, and clicking on the button Modify Selected , details of the particular group/customer can be modified. By selecting a Group/Customer, and clicking on the button Remove selected , the particular customer/group can be removed from the list.

Note:

If a group is deleted, all the customers within that group are also deleted, provided they are not present in any other group.

If a group is deleted, and a customer within that group is also present in other groups, then that customer will continue to remain in the other groups.

A customer present across various groups cannot be deleted at once. If a particular instance of the customer is selected (that is, within a particular group) and deleted, it only gets removed from that group, but continues to exist in the other groups.

Import and Export of Customer Serials

Exporting Customer Serials from Tally.Developer 9 to Excel File

The Customer Serials, along with the respective details, can be imported from an Excel File, or exported to an Excel File, if required.

Consider the above details of customer serials to be present in Tally.Developer 9. To export these details to excel, go to Tools > Export Customer Serials to Excel .

In the pop-up box that opens, specify the name and path of the Excel file. Click Save to save the excel file with the customer details within it.

The customer details are saved in the Excel file as seen in the figure.

Importing Customer Serials from Excel File to Tally.Developer 9

Customer serials, along with the respective details, can be added manually in the Excel File, to be imported in Tally.Developer 9, from Tools > Import Customer Serials from Excel .