https://help.tallysolutions.com/docs/td9rel54/td9/tally_developer_tools/preference.htm

Tally.Developer 9 Preferences

Preferences are general options for the users to configure.

1. Go to Tools > Preferences .

There are three different tabs for setting the preferences:

Edit/Style Options

Explorer Options

Compiler/Execution Options

2. Specify the appropriate preferences on all tabs and click OK .

Edit/Style Options

There are two different sections in the tab Edit/Style Options namely, Editor Options and Styling Options .

Editor Options

Editor Options are used to change the font style, its size, tab size, and so on. This tab contains various options, namely, Convert TAB to SPACES , Show Line Number , Use Multi-line Commenting , Enable Smart Indenting and Position of file tabs .

Change Font

Click Change Font to alter font style or size.

To change the font of the contents of the Editor window, click OK twice.

Tab Size

This option allows the user to configure the size of the Tab.  In other words, the user can decide how many spaces forward or backward the system should move, on pressing Tab or Shift + Tab , respectively.  This change will reflect in all the existing files, including display of default TDL files.

Convert Tab to Spaces

Select Convert TAB to SPACES to replace Tab to number of spaces.  This helps by maintaining uniformity across all Editors as different editors may have different tab sizes.

Show Line number

To display the line numbers in the editor window, select the option “Show Line Number” from the Editor section of Preferences window.  Enabling Show Line Number will display the current line number on the left of the code.

Multi-line commenting

To enable multi-line commenting in the editor window select the option “Use Multi-line Commenting” from the Editor section of Preferences window.  Multi-line Commenting works in sync with Comment Selected.  In TDL, commenting is possible in either ways, Single Line Commenting (;) or Multi Line Commenting (/**/).

Display Special Character Code

When TDL code is copied from other sources like Microsoft Word or a HTML page, and used in Tally.Developer 9 editor, it is possible that certain special characters get inserted in the code. A few of these non-ASCII characters (128-255), like no-break space character, might be invisible. In such cases when the declaration and the description of the definition do not have the same special characters, the TDL code does not get compiled, and thus fail to execute. To identify such special characters, Tally.Developer 9 is enhanced by adding a new option Display Special Character Code in Preferences window. Enable the option Display Special Character Code to identify and display such special characters in the code. Once the special characters are identified, you can perform necessary actions on such characters and compile the project without errors related to special characters.

Consider the code snippet given below, copied from a web page, where the special characters no-break space and copyright sign© are present in the code. The copyright sign is visible but not distinct from the code, and the no-break space is invisible. When you open such TDL code in Tally.Developer 9 releases earlier to Release 6, the special characters were part of the code, or not visible. Hence the developers were getting errors during compilation.

In release 6 or later, when you enable the option Display Special Character Code in Preferences window these special characters display in the editor window as shown below:

Now, the developer can easily identify the characters and perform the necessary actions to proceed with the compilation.

Enable Smart Indenting

To enable Smart Indenting option in the editor screen select the option "Enable Smart Indenting" from the Editor options sections from the Editor/Style Options tab.  This option enables smart indenting that is, the new line is indented according to the previous line type and indentation.

Position of File Tabs

By default, the file tabs are visible at the Bottom of the Editor Window. The position of the file tab pane can be changed to the top of the Editor Window by selecting the option Top, or it can be made invisible, by selecting the option None.

Show Auto Complete From

It can be used to set the number of characters after typing which, the auto-complete behaviour is automatically displayed, wherein we get the list of options to choose from to complete the particular word.

Styling Options

Styling preferences allows option to under line the references and to select the text case for display purpose only.

Make Underline References

To underline the references in the editor window select the option Make References Underlined from the Styling section of Preferences window.

Key Word Case

In this section, the text case to display the text in Editor window can be altered from the Edit/Style Options section of the Preferences window. Select the appropriate case from the options 'UPPER CASE', 'lower case' and 'Normal case'.

Explorer Options

If the option Folder-wise view in Project Explorer is selected,  it will display folder-wise structure for projects.  Otherwise all the files will be displayed as they are.  The application should be restarted to reflect the changes.

The option Restore Last Project and Files on Startup is provided in Preferences to restore the last project and files on startup.

If the option Category-wise view in Function Browser is selected, then in the Function browser the functions are displayed category-wise.

If the option Show errors in Project Explorer is selected, the files with errors are displayed in red in the Project Browser.

In the section Action Browser View Style, if the option Alphabetically is selected  then the actions are displayed alphabetically in the Action Browser. The action list can be displayed Category-wise and Definition-wise as well.

Reference Project Loading:

Check Default TDL to load the default TDL. Base TDL is also loaded.

Check Base TDL Only to load only the Base TDL.

Compiler/Execution Options

There are two sections in the tab Compiler/Executions options:

Compiler Options

Execution Options

Compiler Options

Author Name

Every Project created and compiled in Tally.Developer 9 has name of the Author within it. While creating every Project, the Author Name is asked. By default, the Author Name specified in this field is being set and if required, the same can be altered through the preferences dialog box.  The following screen displays the Author Name set in Preferences .

Saving unsaved files in project before Build/Compile

Whenever we try to compile/build a project with unsaved files, TD9 responds depending upon the option we have selected from the three  available options, that is, Save All Files , Ask Before Save , and Continue Without Saving.

Save All Files saves the changes made to the files automatically, before compiling/building the project.

Ask Before Save directs the editor to ask the user with the help of a pop-up box, if the changes are to be saved.

Continue Without Saving directs the editor to proceed with the compile/build process, without considering the unsaved changes.

Execution Options

Execution Options section takes care of configuring and executing Tally with the project/tdl specified. Consider the image given below for understanding the Execution Options in detail.

The following are the steps for configuration:

Specify the Tally.ERP 9 path for the option Tally.ERP 9 Exe Path.

To execute the Project/File in Tally with/without the TDLs,  specify the .ini file path in the Working Directory .

Additional TDLs to be loaded can be specified with /TDL command line argument, example, /TDL: tdlfilename.tdl . Multiple files can be specified in this way in the Command Line Parm edit box.

If the Ignore TDLs from INI checkbox is selected or /NOINITDL command line is specified in the Command Line Parm edit box, the  TDLs specified in the ini file are not loaded in the Tally that is launched.

If the option Load Default/ Base TDL Reference from TDL from Tally.ERP9 exe path is enabled, Tally.Developer 9 opens the Default TDL from the path mentioned in the field Tally.ERP 9 Exe Path .

Similarly, additional companies can be loaded with /LOAD command line argument. Multiple companies can also be specified.