https://help.tallysolutions.com/docs/td9rel54/td9/using_the_editor/editor_window.htm

Editor Window

Editor Window appears on the right hand side, is the work area available for the TDL programmer. The contents of the file are displayed, added or altered in this window.

Default TDL files (files belonging to the Default TDL project) cannot be altered. They are available only for reference.  The Default TDL codes can be used by copying the same to the working project file.

Any file can be opened in the Editor window by double-clicking the particular file in Project Browser or by using the Drag-and-Drop feature, wherein a file can be opened from any location, by using the mouse to drag the file from its location to the Tally.Developer 9 screen. Double-clicking the file (.tdl or .tpj file) launches the file in a new instance of Tally.Developer 9.

Tab Toolbar

The opened files are displayed as Tabs at the bottom of the Editor Window. The position of the Tab Toolbar can be altered, or it can made to disappear at all, from Edit/Style Options in Tools > Preferences . See Changing Editor Preferences for more details.

For more details on the working and features of the Tabs, refer to the topic Working with File Tabs.

Copy-Paste Operations

A lot of copy-paste options are available to give enormous flexibility to the programmer:

Multi-Location Copying : Multiple locations can be selected at a time by holding down the Ctrl key and selecting the required locations/lines. On copying( using Ctrl +C), all the multiple selected areas will get copied. These lines can be pasted at a place using Ctrl + V, or at multiple places by selecting the multiple areas (by pressing down Ctrl key), and then using Ctrl + V to paste.

Multi Location Pasting : Content selected from an area/multiple areas can be pasted at multiple places at a time. This is done by selecting the multiple places, pressing down the Ctrl key, and then using Ctrl + V to paste.

Rectangular Area Selection : A rectangular area can be selected by using the combination of Alt + Shift + <Arrow keys> keys to form a rectangular area from the current cursor location. This area can then be copied using Ctrl + C , and then pasted at single/multiple areas by pressing the Ctrl key, and then using Ctrl + V combination to paste.

Menu Options

On Right Click in Editor Window, a pop up menu is displayed . It contains various options viz. Include New File , Include Existing File , Compile This File , Explain this Error , Go To Line Number , Go To Bookmarks , Search , Go To Parent File , My Includes , and so on.

Usage of the various options is explained below:

Include New File allows the user to include a new file to the current file/project.

Include Existing File allows the user to include an existing file to the current file/project.

Compile This File is used to compile the currently opened file.

Explain This Error is used to display more information on the error.

Go To Line Number option is used to go to the particular line number in the current file.

Go To Bookmarks allows the user to traverse through the bookmarks present in the file.

Go To Parent File option is used to go back to the parent file.

My Includes option allows the user to navigate to the included files by selecting the file name from the pop-up list.

Adding Bookmarks

Bookmark capability has been provided in Tally.Developer9 to mark specific areas of a program that the user may want to highlight.

Bookmarks can be added by using the hot key Ctrl + F2 or by using the toggle bookmark icon available on the Tally.Developer9 toolbar. They can also be added from the Navigate menu, i.e., by going to Navigate > Toggle Bookmark .

Once a bookmark has been added to a line in the program, it can be revisited by using the icon for Bookmarks menu from the toolbar. We can also go to Navigate > Bookmarks for the same.

For more details, refer to the topic Bookmarks Navigation .