https://help.tallysolutions.com/docs/ts9rel54/ts9/gateway_server_compatibility.htm

Gateway Server Compatibility

The release of Tally.Server 9  should be compatible  with the version of  Tally Gateway Server. If a lower version of the Tally Gateway Server is used, Tally.Server 9 displays an error message as shown below:

Install the latest Tally Gateway Server to continue.