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Licensing Errors – FAQ

This topic lists the licensing error messages and queries related to licensing in TallyPrime. Click any of the links for more information. For help with specific errors, refer to the Error Codes article.

Queries

Yes, you can use your Tally.ERP 9 license in TallyPrime, provided that you have a valid TSS.

To learn more:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

Cause: This could be happening because of the latest security patch of Windows 10 - KB5000808. This Windows 10 update has some issues with a few printers and therefore shows unusual errors when you try to print from any application. In such instances, as you open TallyPrime, Windows 10 application may crash with the following message:

 

Solution

You may try to do one of the following options:

Option 1

  1. Check if any other Windows 10 update is available and upgrade accordingly.
  2. Start TallyPrime application.

Option 2

  1. Uninstall the patch KB5000808.
  2. Install the earlier Windows 10 patch.
  3. Open TallyPrime.

Yes, you can use the same license in Tally.ERP 9 and TallyPrime, provided that you have a valid TSS.

To learn more:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

  • If you have a license for Tally.ERP 9 with a valid TSS, then you can use the same license in TallyPrime.
  • If you have a license, but don't have a valid TSS, then you can purchase TSS and use the license in TallyPrime.
  • If you do not have a license, then you can purchase the license and activate it in Tally Prime.

To learn more:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

No, you do not have to surrender your license in Tally.ERP 9. When you use the same license in TallyPrime, you will be given the option to surrender and reactivate the license automatically.

The following message will appear:

Click Yes. Your license will be reactivated in TallyPrime.

To learn more:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

No, you do not have to surrender your license from the previous computer.

When you reactivate your license in your current computer, the following message will appear.

Click Yes. Your license will be surrendered from the other computer and reactivated on the current computer. 

No, you do not have to surrender your license in TallyPrime before upgrading you Operating System (OS). When you use the same license in TallyPrime (after upgrading your OS), you can directly reactivate your license there. During the reactivation in TallyPrime you will be given the option to surrender and reactivate the license automatically. 

While reactivating, the following message will appear.

Click Yes. Your license will be reactivated in TallyPrime.

To learn more:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

 

If you are using your license in Tally.ERP 9, then you can check the validity in the bottom panel in the Licensing and Services section.

If you are using your license in TallyPrime, then you can check the validity from the Manage License screen:

Press F1 (Help) > Settings > License > Manage License, or click the top left corner on the screen below the TallyPrime icon. For example, you can click the Silver icon in the following screen:

The following screen will appear:

If you do not have a valid Tally license, then you can purchase one.

If you are using your license in Tally.ERP 9, then you can check TSS validity in the bottom panel in the Licensing and Services section.

If you are using your license in TallyPrime, then you can check the validity from the Manage License screen:

Press F1 (Help) > Settings > License > Manage License, or click the top left corner on the screen below the TallyPrime icon. For example, you can click the Silver icon in the following screen:

The following screen will appear:

If you do not have a valid TSS, then you can purchase one.

Yes, a valid TSS is required to upgrade to TallyPrime. If you have a license, but don't have a valid TSS, then you can purchase TSS and use the license in TallyPrime.

Your existing Tally.ERP 9 license can be used to to work in TallyPrime application, provided you have a valid TSS. Tally Software Services (TSS) provides you with the ability to upgrade your application from Tally.ERP 9 to TallyPrime.

Yes, you can use any number of TallyPrime instances in the same computer.

Yes, you can move TallyPrime from one computer to another.

  • Surrender the license from the computer where the license is active.
  • Reactivate the license in the computer where you want to use it.

Yes, you can use more than one Release of TallyPrime in the same computer.

  • If you have a Silver edition license, you can use two different Releases at the same time using the Tally Gateway Server, provided that the latest version of the Tally Gateway Server is installed.
  • If you have a Gold edition, you can use multiple releases at the same time.

You can activate your TallyPrime license as a Multi-Site Account. Your license will be added as one of the Site license under the existing account.

You need to log in to the Control Centre to reject the Site license activation request. Refer to the Control Centre article for more details.

E-Returns can be filed from TallyPrime even without a valid TSS subscription.

This message appears when the license activated in a computer is reactivated elsewhere, and TallyPrime goes into Educational Mode.

You can continue using the licensed version of TallyPrime by configuring to an existing Tally Gateway Server or you can reactivate the license here.

Click the TallyPrime Edu icon on the top left corner of the screen, or press F1 (Help) > Settings > License > Manage License.

The Silver edition is a single-user license. Only one user can access the license at a time in a LAN environment. For another user to access the same license, all other instance(s) of TallyPrime currently using the license must be closed.

For example, TallyPrime is installed in System A, you can use the license in System B (connected in the same LAN) after closing all instances of TallyPrime in System A.
To use the license in System B

  1. Close all instances of Tally in System A.
  2. Start TallyPrime in System B.
  3. Press F1 (Help) > Settings > License > Manage License.
  4. From the Manage License screen, press F4 (Use License From Network) > select Configure License Manually.
  5. Enter the Compute Name/IP and Port , where the license is activated.
  6. Press Enter. A message Restart TallyPrime to apply the changes? is displayed. Click Yes to save.

Windows Firewall might prevent the transfer of data through a port in the system, and is not specific to any Tally product. However, Windows Firewall may prevent the activation of a license which is obtained through an internet port. Hence, it is important to allow Tally files through the Windows Firewall.

To perform any licensing operations such as license activation, reactivation, surrender, or update license, the user should log in as an administrator, or possess administrative rights. When the User Account Control is set to Always Notify, the application will not run in the administrative mode even though the user has logged in as administrator or with a user account having administrative rights.

To run the application in administrative mode:

  1. Go to the TallyPrime application folder.
  2. Right-click tally.exe.
  3. Select Run as administrator.

Alternatively, to change the User Account Control settings:

  1. Click Start.
  2. Select Control Panel.
  3. Click User Accounts and Family Safety.
  4. Click User Accounts in the User Accounts and Family Safety screen.
  5. Click Change User Account Control settings in the User Accounts screen.
  6. Move the slide bar downwards and set to Never Notify in the User Account Control Settings screen.
  7. Click OK.
  8. Restart the system for changes to take effect.
  9. You can now proceed to activate, reactivate, surrender, or update the license.

Cause: The option to configure your TallyPrime license through a license file has been removed from Release 6.6.1.

Solution: You can try configuring to an available Tally Gateway Server.

You can get the unlock key directly from TallyPrime by pressing F1 (Help) > Settings > License > Manage License > press F6 (Unlock).

Alternatively, you can get the unlock key from Tally Solutions website, by providing the Tally product serial number.

  1. Go to the Tally Solutions website.
  2. Click SUPPORT.
  3. Scroll down, and click Get Unlock Key for Activation. The Unlock Key Service screen appears.
  4. Enter the Tally product serial number, and click Get Unlock Key. The unlock key for your Tally Product serial number will be displayed.

You can use this key to unlock and use your Tally product.

An Account is created once you activate your license. An account contains your license details, user details, and so on. An account is identified by a unique Account ID. Log in to the Control Centre to view your account.

An Account ID helps in easy identification of your account. The Account ID is created during activation, and by default, the administrator e-mail ID provided during activation is the Account ID.

You can add multiple licenses to an account using the same Account ID during activation. You can use the Account ID to perform licensing operations, use Tally Software Services, like Synchronisation, and so on.

You can log in to the Control Center and alter the Account ID, if required.

License co-existence has been provided to support users who want to use their license in both Tally.ERP 9 and TallyPrime at the same time.

This is achieved by providing/allowing TallyPrime Gateway Server (version 11.0) to support Tally.ERP 9  clients. The co-existence of Tally.ERP 9 and TallyPrime will be supported for some time.

To find out more about how to use the same license for both Tally.ERP 9 and TallyPrime:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

Yes, you can continue working on Tally.ERP 9 for some time.

License co-existence has been provided to support users who want to use their license in both Tally.ERP 9 and TallyPrime at the same time.

To find out more about how to use the same license for both Tally.ERP 9 and TallyPrime:

Refer to the topic Single Site Licensing in TallyPrime

Watch the video Use Existing Tally.ERP 9 License in TallyPrime

Error Messages

Cause

This error occurs when your license is active on another computer. 

Solution

Click Yes on the error message. Your license will be surrendered from the other computer and reactivated on the current computer.

Note: You do not have to surrender your license separately. It will be automatically surrendered and reactivated once you click Yes.

This message appears when you try to reactivate a license which is already active in the same network. Click Yes to configure this license, or click No, if you want to surrender it from the given Tally Gateway Server, and reactivate the license here.

Cause: This occurs during activating or reactivating License.

Solution:

  1. Delete all the Tally.dmp files and Gatewayserver.dmp files from the TallyPrime application folder.
    You can open the Application Folder from the About page: Press F1 (Help) > About, and click Application Path under the Product Information section.
  2. Set the permission of Tally Gateway Server to full control: Right click Tallygatewayserver.exe > Properties > Security Control.
  3. Click Add in the Permissions for tallygatewayserver.exe screen.
  4. Enter Everyone, click Check Names, and click Ok.
  5. Select Everyone and set the permission as Full Control and click Apply.
  6. Restart the computer and reactivate the license.

Cause: This error occurs when a user with insufficient rights tries to activate, update, or perform any operation that requires accessing the license file.

Solution: Check the security settings of the license file, and clear the Read-only option, and retry.

Cause: This message appears when the specified license file is already in use on a Tally Gateway Server.

Solution: You can either configure the Tally Client to that Tally Gateway Server or surrender it from the given Tally Gateway Server, and reactivate the license here.

Activate/reactivate the License, or select a License from the network. You also have more options in the Manage License report.

Note: If a multi-user (Gold) license needs to be reactivated/configured, you need to reactivate the server system first and configure the client system using the same license. Do not reactivate the license on the client system.

Cause: This error occurs when the system where the license is activated is not connected to the Internet after the offline limit has been reached. For example, if the offline limit for a license is set to 30 days, and the computer is not connected to the Internet for more than 30 days, then the license will switch to Educational mode.

Solution: Connect the system to the Internet and try again.

Cause: This message appears when you try to update the license without valid administrator login details.

Solution: Use account or site administrator e-mail ID and password to continue.

Cause: This error appears when TallyPrime is in the Educational Mode, and you are trying to perform an action that can be carried out only in the licensed mode.

Solution: Activate/reactivate the License, or select a License from the network. You also have more options in the Manage License report.

Cause: This error occurs when the number of Tally Client instance accessing the same license through Tally Virtual User (TVU) exceeds the permissible limit. TVU is a Tally client instance that is used or accessed in windows RDP or similar virtualised environment (such as Application/Desktop virtualisation tools like windows thin client, Citrix, and so on.)

Solution: Close one or more TallyPrime instances accessing through Tally Virtual User and retry.

Note: RDP has been renamed as TVU from Release 6.6.1.

Cause: The message appears while performing a new installation over an existing one, and the gateway server could not be replaced. It may also occur if the gateway could not be replaced while upgrading the product to the latest release.

Solution: To fix the problem, stop the gateway manually using the Window's services menu or task manager, and try again.

Cause: This error occurs when one or more files in the installation folder are in use.

Solution: Close all running instances of files in the installation folder and try again. If you are using the online installer, retry the installation, or download the full installer from the download center, then reinstall it.

Cause: The installation of product help can fail if the installer is corrupted, or if old help files in the installation folder are already open, and in use.

Solution: Close all open instances of the help file and reinstall it. If the installation fails again, download a new help installer from the download center, and try again.

Cause: This message appears during installation using an online installer or during an upgrade, as TallyPrime Installation Pack download is interrupted due to an interruption in the internet connection.

Solution: Connect to the internet and try again.

Cause: The error occurs when an antivirus or Firewall prevents communication with the TallyPrime server.

Solution: Click Add TallyPrime Program Files to Exception List of Windows 7 Firewall to learn how you can prevent the error from occurring in the future.

Cause: This error occurs when the gateway server could not be replaced when installing a new instance over an existing installation or upgrading the product to the latest release.

Solution: Stop the gateway manually using the Windows services menu or task manager and try again.

Cause: This error occurs when a user with insufficient rights attempts to activate, reactivate, update, or perform any operation that requires administrator rights in TallyPrime.

Solution: Click Yes in the message displayed and enter your system administrator username and password at the Windows UAC prompt. TallyPrime will restart with administrator rights.

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