OAuth – Errors & Resolutions
This section lists common errors that may occur while sending e-mails in TallyPrime, along with their causes and solutions.
Cause:
This message appears when the e-mail address or password is incorrect, or when the Gmail or Yahoo account is not authenticated for use with TallyPrime.
Resolution:
Authenticate your Gmail or Yahoo account correctly and ensure that the login details entered are valid.
For Gmail
- Press L (Login via Browser) > Sign in with Google > Select your account > select Send email on your behalf.
- Click Continue.
To change your Yahoo Mail settings to use your E-mail ID from TallyPrime,
- Log in to your Yahoo account.
- Select Account Info > Account Security.
- Add Two-step verification and generate App passwords.
- Click Done.
Cause:
When the attachment size exceeds the limit allowed by your e-mail provider. For example, Gmail allows attachments up to 25 MB.
Solution:
Ensure that the file size is within the allowed limit. You can reduce the report period or attachment size before sending the e-mail.
Cause:
This message appears when SMTP Client Authentication is not enabled.
Resolution:
To enable SMTP client authentication
- Log in to the Powershell and connect to Office 365.
- Set-TransportConfig -SmtpClientAuthenticationDisabled $False
The above procedure should be tried with the help of system administrator.
Cause:
Appears when the e-mail address entered in the E-mail from field contains invalid characters (for example, /).
Resolution:
Verify the sender e-mail ID and ensure it is entered correctly without any invalid characters.
- Press Alt+M (Share), then enter a valid e-mail address in E-mail from field.
Ensure there are no special characters like (/) in the field. - Press Ctrl+A to save.
Cause:
Appears when the e-mail address entered in the E-mail to field contains invalid characters (for example, /).
Solution:
Verify the recipient e-mail address and ensure it is correct before sending the e-mail.
- Press Alt+M (Share), then enter a valid e-mail address in E-mail to field.
Ensure there are no special characters like (/) in the field. - Press Ctrl+A to save.
Cause:
This message appears when the e-mail address used for browser login is different from the e-mail address selected in TallyPrime.
Resolution:
Ensure that you log in through the browser using the same e-mail ID that is configured in TallyPrime.
- Press L (Login via Browser).
- In the browser, select the same Gmail account configured in TallyPrime.
- Press Continue on the Google sign-in screen.
- Select Send e-mails on your behalf option, and press Continue.
Cause:
Occurs when all required permissions are not allowed during browser login.
Solution:
Allow all the permissions requested during the Login via Browser process.
- Press L (Login via Browser).
- In the browser, select your Gmail account configured in TallyPrime.
- Press Continue on the Google sign-in screen.
- Select Send e-mails on your behalf option.
- Press Continue.
Cause:
This message appears when the browser login is not completed and the Verify Login & Send button is clicked.
Resolution:
Complete the login process in the browser and then proceed to click Verify Login & Send in TallyPrime.
- Open any report and press Alt+M (Share).
- Press Ctrl+M (Current) to share the report.
Select Others for Multi-Account Reports. - In the E-mail from field:
- New users: Select Create and set up a new e-mail profile.
- Existing users: Select an e-mail profile from the List of Profiles.
- In the E-mail to field, select New Address, Multiple Address, or Show Last Used, as required.
- Set Show Additional Options to Yes, enter the required details.
- Press M (E-mail).
- To use OAuth-based authentication
- Press L (Login via Browser).
Alternatively, press Ctrl+P (Login with App Password) to use an app password. - Based on the service provider, the authentication page opens in the browser.
- Click Sign in with Google (or the relevant provider) and choose an account.
- New users: Select Use another account and enter the e-mail ID and password.
- Existing users: Select the same account configured in TallyPrime.
- Grant the required permissions.
- For Google, select Send email on your behalf and click Continue.
- For Microsoft, click Accept to approve permissions.
- Once your login is successful, close the browser window.
- Press L (Login via Browser).
- Return to TallyPrime, and press S (Verify Login & Send).
Cause:
Occurs when incorrect SMTP configuration details are entered while creating the e-mail profile.
Solution:
Verify and enter the correct SMTP settings in your e-mail profile.
Cause:
Occurs when the e-mail account is not granted the required permission to send e-mails.
Solution:
- Contact your account administrator to enable the required permissions at the account level.
- Ensure that the necessary permissions are granted to TallyPrime to send e-mails.
