Table of Contents

 

OAuth – Errors & Resolutions

This section lists common errors that may occur while sending e-mails in TallyPrime, along with their causes and solutions.

Cause:
This message appears when the e-mail address or password is incorrect, or when the Gmail or Yahoo account is not authenticated for use with TallyPrime.

Resolution:
Authenticate your Gmail or Yahoo account correctly and ensure that the login details entered are valid.

For Gmail

  1. Press L (Login via Browser) > Sign in with Google > Select your account > select Send email on your behalf.
  2. Click Continue.

To change your Yahoo Mail settings to use your E-mail ID from TallyPrime,

  1. Log in to your Yahoo account.
  2. Select Account Info > Account Security.
  3. Add Two-step verification and generate App passwords.
  4. Click Done.

Cause:
When the attachment size exceeds the limit allowed by your e-mail provider. For example, Gmail allows attachments up to 25 MB.

Solution:
Ensure that the file size is within the allowed limit. You can reduce the report period or attachment size before sending the e-mail.

Cause:
This message appears when SMTP Client Authentication is not enabled.

Resolution:

To enable SMTP client authentication

  1. Log in to the Powershell and connect to Office 365.
  2. Set-TransportConfig -SmtpClientAuthenticationDisabled $False

The above procedure should be tried with the help of system administrator.

Cause:
Appears when the e-mail address entered in the E-mail from field contains invalid characters (for example, /).

Resolution:
Verify the sender e-mail ID and ensure it is entered correctly without any invalid characters.

  1. Press Alt+M (Share), then enter a valid e-mail address in E-mail from field.
    Ensure there are no special characters like (/) in the field.
  2. Press Ctrl+A to save.

Cause:
Appears when the e-mail address entered in the E-mail to field contains invalid characters (for example, /).

Solution:
Verify the recipient e-mail address and ensure it is correct before sending the e-mail.

  1. Press Alt+M (Share), then enter a valid e-mail address in E-mail to field.
    Ensure there are no special characters like (/) in the field.
  2. Press Ctrl+A to save.

Cause:
This message appears when the e-mail address used for browser login is different from the e-mail address selected in TallyPrime.

Resolution:
Ensure that you log in through the browser using the same e-mail ID that is configured in TallyPrime.

  1. Press L (Login via Browser).
  2. In the browser, select the same Gmail account configured in TallyPrime.
  3. Press Continue on the Google sign-in screen.
  4. Select Send e-mails on your behalf option, and press Continue.

Cause:
Occurs when all required permissions are not allowed during browser login.

Solution:
Allow all the permissions requested during the Login via Browser process.

  1. Press L (Login via Browser).
  2. In the browser, select your Gmail account configured in TallyPrime.
  3. Press Continue on the Google sign-in screen.
  4. Select Send e-mails on your behalf option.
  5. Press Continue.

Cause:
This message appears when the browser login is not completed and the Verify Login & Send button is clicked.

Resolution:
Complete the login process in the browser and then proceed to click Verify Login & Send in TallyPrime.

  1. Open any report and press Alt+M (Share).
  2. Press Ctrl+M (Current) to share the report.
    Select Others for Multi-Account Reports.
  3. In the E-mail from field:
    1. New users: Select Create and set up a new e-mail profile.
    2. Existing users: Select an e-mail profile from the List of Profiles.
  4. In the E-mail to field, select New Address, Multiple Address, or Show Last Used, as required.
  5. Set Show Additional Options to Yes, enter the required details.
  6. Press M (E-mail).
  7. To use OAuth-based authentication
    1. Press L (Login via Browser).
      Alternatively, press Ctrl+P (Login with App Password) to use an app password.
    2. Based on the service provider, the authentication page opens in the browser.
    3. Click Sign in with Google (or the relevant provider) and choose an account.
      1. New users: Select Use another account and enter the e-mail ID and password.
      2. Existing users: Select the same account configured in TallyPrime.
    4. Grant the required permissions.
      1. For Google, select Send email on your behalf and click Continue.
      2. For Microsoft, click Accept to approve permissions.
    5. Once your login is successful, close the browser window.
  8. Return to TallyPrime, and press S (Verify Login & Send).

 

Cause:
Occurs when incorrect SMTP configuration details are entered while creating the e-mail profile.

Solution:
Verify and enter the correct SMTP settings in your e-mail profile.

Cause:
Occurs when the e-mail account is not granted the required permission to send e-mails.

Solution:

  • Contact your account administrator to enable the required permissions at the account level.
  • Ensure that the necessary permissions are granted to TallyPrime to send e-mails.
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