HomeTallyPrimeTaxation ComplianceKSA VATKSA - Errors and Resolutions

 

Explore Categories

 

 PDF

Resolution:

  1. Press F11 (Company Feature) > Enable Value Added Tax (VAT): Yes.
  2. In the VAT Details screen, configure for e-Invoice integration.
    1. Set e-Invoice Integration Phase applicable to Yes.
    2. Enter Applicable from date.
  3. In the e-Invoice Login Credentials screen, press G (Generate) to generate the OTP.
    e-Invoice-login-credentials
  4. In the Certificate Signing Request (CSR) Form, change the last 2 digits of Organization Unit to make them unique.
    csrform
  5. Resubmit the form.

Cause: This error occurs when the Company name and VAT no. in the e-Invoice certificate are changed or modified in TallyPrime.

Resolution: Verify that the the Company name and VAT no. in TallyPrime exactly match the details specified in the e-Invoice certificate, which is saved in the company data folder.

Cause:

This error occurs if there is an issue in the ZATCA platform.

Resolution:

You can connect with your ZATCA Relationship manager.

Cause:

This error occurs if there is an issue in the ZATCA platform.

Resolution:

You can connect with your ZATCA Relationship manager.

Resolution:

If it is a B2B or export transaction, provide the Postal Code of the party in the party ledger. However, you can also provide the details while recording a transaction.

Resolution:

Provide the details related to party’s address, building number, portal code, city, district and country in the party ledger. However, you can also provide the details while recording a transaction.

Resolution:

If it is a B2B or export transaction, provide the party’s address in the party ledger. However, you can also provide the details while recording a transaction.

Resolution:

  1. Open TallyPrime and press F11 (Company Features).
  2. Press Ctrl+I (More Details) > e-Invoice Integration Phase (History).
  3. If the latest status is not onboarded or renewed, complete the onboarding process.

Resolution:

If you are seeing this error message under the Ready for e-Invoice Generation section in the e-Invoice Overview Report, then it is an unexpected error message. Connect with TallyCare to resolve the error.

If you are seeing this error message under the e-Invoice Generated section in the e-Invoice Overview Report, then it is an expected error message.

Cause:

This error occurs, if you have altered some values in the voucher and saved the voucher without opening the e-Invoice details.

Resolution:

If you have altered some values in the document,

  1. In TallyPrime, open the voucher in the alteration mode.
  2. Open e-Invoice details.
  3. Ensure that the e-Invoice details are correct and press Ctrl+A to save.
  4. Press Ctrl+A to save the voucher.

Cause: 

This error occurs, when the tax type of the transaction is something other than Taxable tax type.

Reason:

You have to fill in the category code reason with valid details.

  1. Open the stock item or ledger in the alteration mode
  2. Under Statutory Details, select the Reason Code and Reason Text for Reason for tax exemption/zero rate.
  3. Press Ctrl+A to save.

Cause:

This error occurs when the stock item and ledgers have negative value.

Resolution:

Instead of a negative value, enter a positive value in the stock item and ledger.

TallyHelpwhatsAppbanner
Is this information useful?
YesNo
Helpful?
/* */