Table of Contents

 

Invalid GSTIN | GSTIN/UIN is not specified/invalid | Invalid Supplier GSTIN | Invalid Consignee GSTIN

Cause

Invalid GSTIN (For Company or Party)

GSTIN/UIN is not specified/invalid (For Company or Party)

Invalid Supplier GSTIN (For Company)
Invalid Consignee GSTIN (For Party)

Resolution

Update GSTIN/UIN of Company

  1. Press F11 (Features) to open the Company Features Alteration screen.
  2. Set Enable Goods and Services Tax (GST) to Yes.
  3. Under the GST Registration Details, update with the correct GSTIN/UIN and save.

To know more, refer to Specify Company GST Registration Details.

Update GSTIN/UIN of Party

Validate the party’s GSTIN/UIN and update the correct GSTIN.

  1. Press Alt+G (Go To) > Alter Master > Ledger > select the party ledger.
  2. Press Alt+L (Fetch Details Using GSTIN/UIN).
    For TallyPrime 2.1 & earlier, press Alt+L (Get GSTIN/UIN Info).
  3. Press Y to confirm and log in using your e-Invoice or e-Way Bill credentials, if prompted.
  4. In the GSTIN/UIN Info screen, verify the details entered in the party master against the details as on the portal and make necessary changes under As per Books, if needed.

You can verify your GSTIN/UIN in the GST portal, as well.

If you know the correct GSTIN/UIN of the party, you can update the GSTIN/UIN for either a single party or multiple parties.

For a single party

  1. Press Alt+G (Go To) > Alter Master > Ledger > select the party ledger.
  2. In the Ledger Alteration screen, update the GSTIN/UIN and save.

For multiple parties, group-wise

  1. Press Alt+G (Go To) > type or select Update Party GSTIN > and press Enter.
  2. Select the group and ledger for which you want to update the GSTIN/UIN.
  3. In the Update Party GSTIN/UIN screen, enter the GSTIN/UIN number for each party and save.

To know more, refer to Update Party GSTIN.

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