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Applicable Tax Ledger is not selected

Cause 1

In the GSTR-3B – Uncertain Transactions (Corrections Needed), you can see the transaction appearing as Tax Ledger is not specified, if you have selected incorrect Tax ledger while passing the transaction.

applicable-tax-ledger-not-selected

If you are on TallyPrime Release 4.1 or earlier, such transactions will appear under ‘Tax Ledger is not specified’ in GSTR-1.

Resolution

  1. In the GSTR-3B – Uncertain Transactions (Corrections Needed), drill down from Applicable Tax Ledger is not selected.
  2. Select the transaction that you want to update, and press Enter to open it in the alteration mode.
  3. Update the relevant Tax ledgers and press Ctrl+A to save the transaction.

The transaction will be resolved with the updated details. Similarly, you can resolve the other transactions.

Cause 2

If you have recorded bank charges with GST using tax ledgers, then these transactions show up as Incorrect Registration Type or Tax Ledger is selected in the Bank transaction under the Uncertain Transactions (Corrections Needed) in the GSTR-3B, GSTR-2A, and GSTR-2B reports. This happens because the selected bank is treated as an Unregistered party by default, instead of Regular.

incorrect-registration-type-or-tax-ledger

Resolution

In TallyPrime Release 5.1 and later versions, you can update this uncertain transaction in the GSTR-3B, GSTR-2A, and GSTR-2B reports by changing the Registration Type of the bank to Regular.

  1. In GSTR-3B – Uncertain Transactions (Corrections Needed), drill down from Incorrect Registration Type or Tax Ledger is selected in the Bank transaction.
  2. Drill down from the transaction that you want to update, and open the Party Details screen.
    party-details-bank
  3. Update the Registration Type as Regular and press Ctrl+A to save the transaction.

Once you update the Registration Type, the voucher will appear under Included in Returns.

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