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Repairing Company Data – FAQ

Some of the commonly asked questions about repairing company data are answered here.

Cause

This error appears while opening TallyPrime, if

  • The Tally data files .tsf or .900 file is locked by any other process such as third-party backup software or any other application is accessing Tally data files and at the same time Tally application tries to write to the Tally database and it fails.
  • The Antivirus software is blocking Tally data files because Ransomware protection feature is enabled.
  • Microsoft Windows Offline Sync feature is enabled.

 

Solution

  • Exclude .tsf and .900 files from scheduled backup in the third party back up software running in any of the system on LAN.
  • Add Tally data files in the Exception list of Ransomware Protection feature of the Antivirus Software.
  • Enable read write access for the data folder.
  • Add Readretrycount=10 in Tally.ini file and save the file with changes. This command will try to write again in case there is a failure to writing or delay in writing (this parameter will impact the performance. This is because, the system will keep trying to write the data)

This error occurs while attempting to write to disk.

Cause

This error may occur when there is insufficient rights to write to the disk.

Solution

For more information on sharing and access rights of folders, click here.

Cause

This error may occur due to damaged or corrupted Tally files.

Solution

  1. Backup your data.
  2. Ensure that full access is given to the user, to access the files and folders available in the data folder.
  3. Open the required company’s data folder,and check if the size of the file CmpSav.900 is 1KB.
  4. Cut the Company.900 file from the data folder and paste it to the desktop.
  5. Create another copy of CmpSave.900, and rename the file named copy of Cmpsave.900 to Company.900.
  6. Take the existing backup of the corrupted data and perform zero rewrite.
  7. It is also advisable to check the bad sectors in Hard disk.
  8. Restart TallyPrime and check. In case if still issue remains unsolved write to support@tallysolutions.com with the data backup of the company.

 

 

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