Table of Contents

 

e-Invoice Rejected Due to Invalid Address Length

Cause
You may encounter the following errors, if the Party address entered in TallyPrime exceeds the 100-character limit allowed in the Address 1 or Address 2 field of the e-Invoice system.

  • The field Address 1 must be a string with a minimum length of 1 and maximum length of 100
  • The field Address 2 must be a string with a minimum length of 3 and maximum length of 100

Resolution

The maximum length of address allowed in the e-Invoice System is 200 characters (100 against address line 1 and 100 against address line 2). TallyPrime combines the address details and includes the maximum possible characters in Address Line 1 and Address Line 2, after truncating the text at the nearest word. However, if address is beyond 200 characters for both the address lines, it will get rejected by NIC.

Therefore, update the address for Party and Company, accordingly to remove any additional or unnecessary details.

Update Party address

  1. Press Alt+G (Go To) > Alter Master > Ledger > select the party ledger.
  2. In the Ledger Alteration screen, update the address under Mailing Details.
    In the Address field enter only street details without State, Country, and Pincode.
    For example, No. 9, S No. 101/1, Phatak Maidan, Satana, Nashik.
  3. Enter State, Country, and Pincode.
  4. Press Ctrl+A to save.

Update Company address

  1. Press Alt+K (Company) > Alter.
  2. In the Company Alteration screen, update the address and save.
    In the Address field enter only street details without State, Country, and Pincode.
    For example, No. 45/2, 3rd Floor, Lakshmi Complex, MG Road, Bengaluru.
  3. Enter State, Country, and Pincode.
  4. Press Ctrl+A to save.
Is this information useful?
YesNo
TallyHelpwhatsAppbanner
Is this information useful?
YesNo
TARA