Error Code 21: License Request file is Read only. Please check the file security settings and try again.

Cause

This error occurs when the tally.lic license file is set to Read-only , or when you do not have Write permission to access the Tally.ERP 9 installation folder.

Solution

Clear the Read-only option for the tally.lic license file in the Tally.ERP 9 installation folder.

Provide Write permission to access the Tally.ERP 9 folder.

To clear the Read-only option for the license file

1. Open the Tally.ERP 9 installation folder.

2. Right-click on the tally.lic file and select Properties . The tally.lic Properties window appears.

3. Clear the option Read-only .

4. Click Apply and OK to save the settings.

To check if you have Write permission to the Tally.ERP 9 folder

1. Right-click on the Tally.ERP 9 folder where the license file tally.lic is available.

2. Select the option Properties . The Tally.ERP 9 Properties window appears.

3. Click the Security tab and select the user who requires write permission to access the folder.

4. Check if you have Write permission in the Permissions for Administrator section.

5. If you have Write permission, click Cancel to exit the Tally.ERP 9 Properties window.

6. If you do not have the required permission, click Edit .

7. Allow the Write permission.

8. Click Apply and OK to save the properties.