Some of the commonly asked questions about rewriting company data are answered here.
If your Tally.ERP 9 data is corrupted, then rewriting your data will help in restoring the original information.
When your company data is corrupted, then one of the following error messages might appear:
● Error Tranmgr.900 or Linkmgr.900 or Manager.900
● Error: File/Size/Position/Chars/Error Code
● Memory Access Violation
● Debug location error
● Data files damaged. Need to rewrite
● File damaged
To rewrite your company data
1. Go to the Gateway of Tally or the Company Info. menu.
2. Press Ctrl+Alt+R . The List of Companies appears in the Rewrite Company screen, as shown below:
3. Select the company for which you want to rewrite data.
4. Press Enter to rewrite the data.
Once the rewriting procedure is complete, you will be able to access your restored data.
If the error still occurs, then you can try zero command rewrite. Ensure that you back up your existing data before performing this action.
1. Go to the Start menu in your MS Windows computer.
2. Click Run and enter Tally.exe followed by <file path> <data path> 0 . For example, C:\Tally.ERP9\Tally.exe data 0 , as shown below:
3. Click OK . The Gateway of Tally appears.
4. Press Ctrl+Alt+R . The List of Companies appears in the Rewrite Company screen, as shown below:
5. Select the company for which you want to rewrite data.
6. Press Enter to rewrite the data.
Note: If you are facing any difficulties while following the above procedure, contact your administrator for assistance.
Cause
This error appears while opening Tally.ERP 9, if
● The Tally data files .tsf or .900 file is locked by any other process such as third party backup software or any other application is accessing Tally data files and at the same time Tally application tries to write to the Tally database and it fails.
● The Antivirus software is blocking Tally data files because Ransomware protection feature is enabled.
● Microsoft Windows Offline Sync feature is enabled.
Solution
● Exclude .tsf and .900 files from scheduled back up in the third party back up software running in any of the system on LAN.
● Add TallyData files in the Exception list of Ransomware Protection feature of the Antivirus Software.
● Enable read write access for the data folder.
● Add Readretrycount=10 in Tally.ini file and save the file with changes. This command will try to write again in case there is a failure to writing or delay in writing (This parameter will impact the performance. This is due to the system will keep trying to write the data)
This error occurs while attempting to write to disk.
This error may occur when there is insufficient rights to write to the disk.
For more information on sharing and access rights of folders, click here .
Upgrade to release 6.4.1 or later, and rewrite your data to resolve this issue.
Rewrite has been initiated and has been stopped in between.
Back up your company data and rewrite.
This error may occur due to damaged or corrupted Tally files.
1. Back up your data.
2. Ensure that full access is given to the user in order to access files and folders available in data folder.
3. Open the required company’s data folder and check if the size of the file CmpSav.900 is 1KB.
4. Cut the Company.900 file from the data folder and paste it to the desktop.
5. Create another copy of CmpSave.900 and rename the file named copy of Cmpsave.900 to Company.900.
6. Take the existing backup of the corrupted data and perform zero rewrite.
7. It is also advisable to check the bad sectors in Hard disk.
8. Restart Tally.ERP 9 and check. In case if still issue remains unsolved write to support@tallysolutions.com with backup data of the company.
Cause
This error message appears while saving a voucher or recording transactions, in a multi-user environment, due to any one of the following reasons:
● A faulty or broken cable especially for an external USB or Fire wire enclosure can generate this error. It could be due to a long cable that is hooked up through a hub that is not up to the required specifications.
● You may be using a 40-pin cable for the UDMA drive when the drive actually requires an 80-pin cable.
● Mechanical failures of drives.
● Access shared data in an unstable network environment with Windows XP operating system. Due to intermittent network failure, writing to shared data files fails, which can lead to this error.
Due to above reasons Tally.ERP 9 data may get corrupted and it has to be rewritten.
Solution
1. Change the faulty broken cable or connect the cable to the Hub with required specifications.
2. Check and replace the UDMA drive cable, if required.
3. Replace the required drive.
4. Reconfigure network for better stability.
Note: This scenario will appear only if you have Windows XP Operating system. It is suggested to migrate the operating system to Windows Vista or Windows 7 and above that has improved file sharing protocol, which take care of intermittent network failures. These prevent delayed write failures causing data corruption and crashes.