Explore Categories

 

Import and Export – FAQ and Errors & Resolutions

Some of the commonly asked questions about import and export of data are answered here. It also includes a few error messages and resolutions.

Import and Export – FAQ

In TallyPrime, you can export and import the entire data to a newly created company. You have to export the masters first and then the transactions. Ensure that company features (F11) of the exporting and the importing company are the same.

Note: The price lists of the old company mentioned in F11 features can be imported and exported in a similar manner to the new company.

 

Export Masters

  1. Press Alt+G (Go to) > type or select List of Accounts > select Ledgers and press Enter.
    Alternatively, Gateway of Tally > Chart of Accounts > Ledgers.
  2. Press Alt+F12 (Range) to select the masters you want to export. Skip this step if you want to export all the masters.
  3. Press Alt+E (Export) > press Enter on Current.
  4. In the Export screen, press C (Configure) > select the File Format as XML (Data Interchange)
  5. The Folder Path will be set to C:\Program Files\TallyPrime. You can change this, if needed.
  6. The File Name will be set to Master.XML. You can change this, if needed.
  7. Set the Type of Master to All Masters.
  8. Press Esc to return to the Export screen.
  9. Press E (Send) to export.

 

Export Transactions

  1. Press Alt+G (Go to) > type or select Day Book.
    Alternatively, Gateway of Tally > Day Book.
  2. Press Alt+F2 (Period) and provide the required From and To dates.
  3. Press Alt+F12 (Range) to select the masters you want to export. Skip this step if you want to export all the transactions.
  4. Press Alt+E (Export) > press Enter on Current.
  5. In the Export screen, press C (Configure).
  6. Select Narration and press Enter to set it to Yes. Similarly, set the required options to Yes.
  7. Set the Type of Vouchers to All Vouchers.
  8. Select the File Format as XML (Data Interchange).
  9. The Folder Path will be set to C:\Program Files\TallyPrime. You can change this, if needed.
  10. The File Name will be set to DayBook.xml. You can change this, if needed.
  11. Press Esc to return to the Export screen.
  12. Press E (Send) to export.

 

Import Masters

  1. Select the required company.
  2. Press Alt+O (Import) > Masters.
  3. In File to import (XML) select the filename containing the exported masters.
  4. In Behaviour of import if masters already exists, select Modify with new data.
  5. Press Enter to import the masters.
    • Once the import process is complete, compare the statistics of both importing and exporting company.
    • To view these details, press Alt+G (Go To) > type or select Statistics > and press Enter.
      Alternatively, go to Gateway of Tally > Display More Reports > Statements of Accounts > Statistics.

 

Import Vouchers

  1. Select the required company.
  2. Press Alt+O (Import) > Transactions.
  3. In File to import (XML) select the filename containing the exported transactions.
  4. Press Enter to import the transactions.
    • Once the import process is complete, compare the statistics of both importing and exporting company.
    • To view these details, press Alt+G (Go To) > type or select Statistics > and press Enter.
      Alternatively, go to Gateway of Tally > Display More Reports > Statements of Accounts > Statistics.

  1. Press Alt+O (Import) > select Configuration and press Enter.
  2. Set the option Ignore errors during import to Yes.

This will avoid programming conflicts that may occur while the data is being imported. Setting this option to 'No' will ignore the error message and continue with the import of data.

Note: However, errors while importing data will be logged into the Tally.Imp file that is generated in the TallyPrime folder.

Scenario 1: While merging multiple company data, transactions are getting overwritten or deleted on importing data of another company.

Scenario 2: While importing third party xml data to Tally, transactions available in Tally database are getting deleted or overwritten.

Reason

  1. If multiple copies of a single company are copied in different locations rather than creating from Tally application, then vouchers will hold same Voucher ID at all the locations.
  2. Consolidation of all the company vouchers using export and import feature will lead to overwriting or deletion of the vouchers as Voucher ID is same in all the companies.
  3. If third party application is generating same Voucher ID for all vouchers, then the above-mentioned problem will occur while importing the xml files.

Solutions

Scenario 1: Create the company from Tally application and import the data by removing the voucher ID with the help of Notepad++.

Scenario 2: For third party software’s, you need to generate unique Voucher ID for each and every voucher.

Below is the XML TAG LINE which should be altered:

<VOUCHER REMOTEID="Unique id has to be provided" VCHKEY="01ae33cc-833c-479e-913c-c5079b964709-0000a46e:00000008" VCHTYPE="Purchase" ACTION="Create" OBJVIEW="Invoice Voucher View">

Additional information

To merge all the current data and to overcome the overwriting or deletion problem, Voucher ID must be removed from daybook.xml files. This can be done using XML editors. Below is the procedure followed for “NOTEPAD++” software.

Note: There are multiple XML editor software, but procedure might vary from one software to another.

Following is the procedure for replacing Voucher remote ID using Notepad++ software.

Step 1

  1. Download the Notepad++ software.
  2. Load the XML file using NOTEPAD++ software.

  3. Press Ctrl+F button -> in Find what field, mention Remoteid=*.*vchtype and in Replace field, mention VCHTYPE. In Search Mode box, enable the option Regular expression and click on Replace All.
  4. After selecting Replace All option, the Voucher ID will be removed from all the Vouchers & message will be displayed as shown below:
  5. Once replacement is completed, you will find the difference in below mentioned tag line:
    • Before replacement:
    • After replacement:

Step 2: Import this daybook.xml to Consolidation Company, so that complete data will get imported.

Note: Ensure to import this xml file only once. If import is done again and again, transactions will get duplicated.

You can export or import a stock item to another new company.

  1. Load both the importing and exporting companies in TallyPrime.
  2. Select the Company from which the Stock Item has to be exported.
  3. Go to Gateway of Tally > Alter > Stock Item.
    Alternatively, press Alt+G (Go To) > Alter Master > type or select Stock Item > and press Enter.
  4. Select the required stock item.
  5. In the Stock Item Alteration screen, press F3 (Company).
  6. In the Change Company screen, select the company in which the stock item has to be imported.
  7. The Stock Item Alteration screen for the selected company appears, press Ctrl+A to save the stock item.

You can export the closing balances of the ledger or item or both on any given date and import the same as opening balances to newly created companies. This facility is provided in TallyPrime.

Export closing balance in old company

  1. Gateway of Tally > Chart of Accounts > Ledgers.
    Alternatively, press Alt+G (Go To) > type or select List of Accounts > select Ledgers and press Enter.
  2. Press Alt+E (Export) > Current.
  3. In Chart of Accounts screen, press C (Configure).
  4. Select the required Type of master or select All Masters to export all the masters to the respective company.
  5. Set the option Export closing balances as opening balance to Yes, to export the closing balances.
  6. Select the File Format as XML (Data Interchange) or SDF (SDF format appears only when TDL is loaded).
  7. In the Export to field, select the path to which the file needs to be exported.
  8. In the File Name field enter the required output file name or accept the default file name.
  9. Press Enter on Show More displayed at the top of the list > set the option Open Folder after export to Yes.
  10. In the Closing balance as on field, press Enter and change the date, as needed.
  11. Press Esc to return to the export screen.
  12. Press E (Send) to export the file.

 

Import as Opening Balance in New Company

Open new company to import the exported closing balances as opening balance.

  1. Press Alt+O (Import) > Masters.
  2. In File to import (XML) select the filename containing the exported masters.
  3. In Behaviour of import if masters already exists, select Modify with new data.
  4. Press Enter to import the masters.

On successfully importing the data you can view the balances for ledgers and stock items.

Use ODBC feature to export customer's/supplier's details to Excel.

  1. Start TallyPrime.
  2. Press F1 (Help) and ensure ODBC Services and port number are displayed.
    Note: Ensure that TallyPrime is open till you complete the process of exporting ledgers details to Excel.
  3. Open Microsoft Excel on your computer.
  4. Click Data > Get External Data > From Other Sources > From Microsoft Query, as shown below:
  5. Click Browse > select TallyODBC64_9000, as ODBC is enabled on the server 9000.
  6. Click OK. The Query Wizard - Choose Columns screen appears as shown below:
  7. Click Ledger and expand the list to select the required fields.
  8. Click Next. The Query Wizard - Filter Data screen with the column names appears as shown below:
  9. Click Next. The Query Wizard - Sort Order screen appears as shown below:
  10. Select Ascending or Descending for each drop down list under Sort by, as required.
  11. Click Next. The Query Wizard - Finish screen appears as shown below:
  12. Select the option Return Data to Microsoft Office Excel.
  13. Click Finish. The Import Data screen appears as shown below:
  14. Click OK. The Microsoft Excel sheet with the imported data appears as shown below:

You can export the Sundry Debtor and Sundry Creditor ledgers to a newly created company.

  1. Gateway of Tally > Chart of Accounts > Ledgers.
  2. Press Alt+H (Multi-Masters) > Multi Alter > select Sundry Debtor/Sundry Creditor from the List of Groups.
  3. Press F3 (Company).
  4. Select the new company.
  5. In the Multi Ledger Alteration screen, press Ctrl+A to save the creditor/debtors ledgers in the new company.

With Open Database Connectivity (ODBC), you can exchange data between TallyPrime and any other application.

The bitness of the following three important elements determines Export of data via ODBC.

  1. TallyPrime
  2. Operating System
  3. Microsoft Office

For seamless functioning of this ODBC feature, it is essential that these three elements are of the same bitness. 

Consider the scenario where the Operating System is 64-bit, TallyPrime is 64-bit and MS Office is 32-bit. Then, by default, Microsoft Excel will not be able to communicate to TallyPrime as it is of a different bitness. To enable data export, installation of the required drivers is needed.

To install the required drivers to enable export of data via ODBC,

  1. Open the TallyPrime application folder.
  2. This folder will contain the files – regodbc32.exe and tallywin32.dat.
  3. Right click the regodbc32.exe and select the option Run as Administrator to install 32-bit ODBC drivers.

Yes, it is possible to store the file on the desktop or any other location by specifying the required path or folder in the Folder Path field of Export screen.

Exporting the Masters and Vouchers separately, and then import them into another company individually is slow and time consuming. Hence, you can export both Masters and Vouchers together. This option is available while exporting the Day Book or all registers. To export the dependent masters and vouchers:

  1. Gateway of Tally > Day Book.
    Alternatively, press Alt+G (Go To) > type of select Day Book > and press Enter.
  2. Press Alt+E (Export) > Current.
  3. Press C (Configure) > type or select Include dependent masters and press Enter to set it to Yes.
  4. Press Esc to return to the Export screen.
  5. Press E (Send) to export.

It is advisable that you do not alter the predefined masters in TallyPrime. If you require groups to be displayed in various reports, create new groups instead of altering the predefined masters.

It is possible to update Excel with the changes made to TallyPrime in real-time. This is possible only when ODBC connectivity is available.

The online update can be done automatically by setting the duration of auto-refresh rate in Excel by following the steps shown:

  1. Click Data.
  2. Click Refresh All.
  3. Select Connection Properties.
  4. By default, Refresh every is checked.
  5. Enter the duration in minutes in Refresh every field. TallyPrime will automatically send the data to excel at the specified duration.
  6. Click OK.

Yes, there is an option to automatically open the exported file in TallyPrime.

  1. From any report, press Alt+E (Export) > Current. The Export screen appears.
  2. Press C (Configure) > select Show More and press Enter.
  3. Set the option Open folder after Export to Yes to automatically open the folder or file immediately after export.

    Files exported to Excel, JPEG (single page), HTML and PDF formats open automatically. Whereas for ASCII, JPEG (multi-page), XML and SDF formats, only the folders open.

To enable SDF format for export/import:

  1. Open the Tally.ini file and set the option User TDL to Yes.
  2. In the next line, remove the semicolons (;;) in TDL and enter the name of the TCP file (i.e., tdl = SDFExportImport.tcp)
  3. Save Tally.ini and start TallyPrime. You can now view the SDF format while performing an Export/Import.

For example, press Alt+G (Go To) > type or select List of Accounts > Ledgers > press Alt+E (Export) > Current > press C (Configure) > select the File Format as SDF > and export the file.

You can know the GUID by exporting any voucher from Daybook in XML format.

Open the exported file in notepad, find the word GUID using Ctrl+F function. You will find a 36 character length alpha numeric string enclosed within (hexadecimal value).

For example, f64a4e48-950f-46f0-90f6-6c054a22fa68-00000002

In the above example, GUID of the company is "f64a4e48-950f-46f0-90f6-6c054a22fa68" and the last part "00000002" identifies the voucher.

To view this option, press Alt+O (Import) > Configuration.

You can set the option Overwrite voucher when a voucher with same GUID exists to Yes/No, while importing vouchers into TallyPrime.

Impact of this option is given below:

Configuration

Export & Import of voucher in the same company 

Exported from one company & imported to another company

Overwrite voucher when a voucher with same GUID exists is set to No

If a voucher is exported and imported back to the same company, a duplicate voucher gets created. The subsequent import of the same voucher will overwrite the previously duplicated/created voucher.

The voucher gets imported once irrespective of whether the option is Yes or No.

Overwrite voucher when a voucher with same GUID exists is set to Yes

If a voucher is exported and imported back to the same company, the existing voucher gets overwritten.

 

No. The option Export closing balance as opening balance is supported only in XML and SDF formats.

Reports exported in HTML, PDF, and JPG formats support company logo.

You can export the data in SDF format.

  1. Press F1 (Help) > TDL & Add-On > press F4 (Manage Local TDLs).
  2. In the TDL Configuration screen, set Load selected TDL files on startup to Yes.
  3. Select the TDL File Name from the path or the folder where the TDL file is stored.
  4. Set Load TDL to Yes.
  5. Start TallyPrime.

In the export configuration screens and you will have the option SDF format along with other available formats.

Export of data is provided mainly for summaries and statements like Trial Balance, Stock Summary, and so on. The main use would be to export data to, for example, a spreadsheet, and reorganise it for statutory presentation, or export it to another company that is using Tally for direct import.

Export of all reports and statements is possible. A separate button E: Export is provided in the button bar. You can press Alt+E (Export) to export the current report. There are various formats available for export.

The exported file is saved in the parent Tally directory on your computer. You can now use that file to import its contents into another program, send it as it is (say if it is HTML file) to a colleague or view it using a browser.

While exporting the data/report/invoice, specify the export location. TallyPrime creates the folder and exports data to the specified location.

The major difference in Restricted (ASCII) and Default (All Languages) is enumerated in the below table.

 

Default (All Languages)

Restricted (ASCII)

 

Only Indian language

Indian language with English alias or vice versa

Only Indian language

Indian language with English alias or vice versa

ASCII

Export happens in the Indian language

The export happens in the selected language

Question mark appears

Export happens in English irrespective of the language selected

Excel

The export happens irrespective of the language

The export happens irrespective of the language

The export happens

The export happens

HTML

The export happens

The export happens

Question mark appears

The export does not have the selected language.

JPG

The export happens with the language

The export happens

The export happens with the selected language

The export happens

Pdf

Question mark appears

Export happens. On changing the language the export to PDF option does not appear

Question mark appears

Export happens in English

XML

The export happens in the selected language

The export happens in the selected language

Question mark appears where Indian language is present

The rupee symbol appears as question mark.

When the language is changed during export the export happens in English

 

Yes, it is possible to perform a one-way snapshot based on the type of sync mentioned in the client rule.

 

Import and Export – Errors and Resolutions

Cause: The tally.imp is in use or open, or the destination folder to which you are trying to export the data, does not have the required permission. It is in read-only mode.

Solution: Change the attributes of the folder as follows:

  • Uncheck the read-only property of the folder by following the steps shown:
    • Right-click on the folder.
    • Select Properties.
    • In the Properties window, clear the check box against the option Read Only.
    • Click OK.
  • Give a different file name and export, or close the file that was opened earlier.

The application MS Excel has not been installed in the machine.

Install MS Excel on the machine, since TallyPrime requires MS Excel to carry out the process of exporting in the Excel (Spreadsheet) format. Once the file is exported, it can be opened using other applications viz, Open Office, Star Office, etc.

Cause: This message appears while importing closing balances from an existing company into a newly created company. Tally.imp file displays the message ERROR: Ledger: Stock The date is Out of Range! Suggest a Solution.

This error occurs when the Stock Ledger is not available in the newly created company.

Solution: The stock ledgers have to be created manually followed by entering the values manually. However, other masters are successfully imported during the import process.

The error Insufficient data for an image occurs when the Company Logo configured for printing Reports/Invoice size is more than the recommended size. Recommended size for company logo is 96 pixels in width x 80 pixels in height. If the logo size is more than recommended then above error exists.

Resize the image into 96 pixels in width x 80 pixels in height using MS paint.

  1. Open the image in MS paint.
  2. Click Resize.
  3. Click on pixels. In horizontal mention 96 and width as 80, and click OK.
  4. Save the image in BMP or JPEG format.
  5. Define the path of the resized logo, to print it on invoices and reports.
    • Press Alt+P (Print) > Configuration.
    • Type or select Include company logo (applicable to Print/Export/Email) and press Enter.
    • Set the option Include company logo (applicable to Print/Export/Email) to Yes.
    • Select the Image Path and the Image File Name.

      You can now export the invoices and reports with the logo (image which is resize) as PDF. You will get the complete data in PDF without any error message.

This message appears when the file name and path specified in Import Transactions screen is incorrect. You need to specify the correct path and then import the data.

Cause: TallyPrime displays this message when it was unable to open or write to Tally.imp due to any one of the following reasons:

  • Tally.imp file is write protected
  • The file is used by another application
  • Another instance of TallyPrime is using this file

In such cases, full permission has to be given to Tally.imp file by following the steps given below:

Solution

  1. Right click tally.imp file in the application folder.
  2. Select Properties.
  3. In the tally.imp Properties window, click Security tab.
  4. Click Edit to change the permissions.
  5. In Permissions for tally.imp window, select the required users.
  6. In Permissions for Authenticated Users check Allow against Full Control.
  7. Click Apply > OK.
  8. Close the instance of TallyPrime which is running on your system.

Unable to validate the exported file (form 24Q), when Q4 (January - March) was selected as the Quarter Period.

 

Cause: The quarter (Q4) selected is not of the respective financial year.

Let us consider that the current financial year selected is 2020-21. When the system date/current date is the month of April, May or June, we can't generate the e-returns for the 4th quarter of 2019-20, and validate the same in the File Validation Utility.

 

Solution: You can generate the TDS returns for the 4th quarter of the previous financial year, by changing the current period of the company.

  1. Gateway of Tally > press Alt+F2 (Period).
  2. Enter 1-04-2019 in the From field and 31-03-2020 in the To field as shown below:

Generate Form 24Q for 2019-2020

  1. Gateway of Tally > Display More Reports > Payroll Statutory Reports > Income Tax > E-24Q.
  2. In the Export screen, select Q4-[January - March].
  3. Press Enter to accept the screen. The exported file is placed in the TallyPrime Directory, which can be validated with the File Validation Utility, downloaded from NSDL website.
Post a Comment