Authentication Failed in Yahoo Mail

While using Yahoo mail, this error message may appear in the following two scenarios:

Scenario 1

Cause

This error message appears when the user name, the password, or both are incorrect.

Solution

     Enter the correct user name and password during authentication.

     Ensure that the Caps Lock key is used correctly.

Scenario 2

This error message may appear even when the authentication details are entered correctly.

Cause

In such a scenario, this error occurs when two-step verification has been enabled in the Yahoo mailing account.

Solution

Disable two-step verification for your Yahoo account.

If you want to retain two-step verification in Yahoo, you have to generate and enter an application-specific password while authenticating mailing details.

To disable two-step verification in Yahoo

     Go to Yahoo > Account Info. > Account security > Two-Step Verification > Turn off.

To generate an application-specific password for your Yahoo account

1.    Go to Yahoo > Account Info. > Account security > Manage app passwords.

2.    Select Tally from the drop-down menu.

3.    Click Generate. Your application-specific password appears.

4.    Follow the instructions below the password.

5.    Click Done.

The generated password has to be entered during authentication (instead of the password of your Yahoo account), as shown below:

A mail can now be sent successfully from Tally ERP 9 even when two-step verification is turned on.